Page 7 of 85 FirstFirst 12345678910111213141757 ... LastLast
Results 61 to 70 of 843

Thread: 1990 S13 Silvia, OEM style...but not!

  1. #61
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    Being shitty is street cred? Woohoo!
  2. #62
    Member cannonball's Avatar
    Join Date
    Mar 2005
    Location
    Abject Poverty
    Daily
    a VN Commodore
    Posts
    179

    I must have the most street credibleicious cars around

    Cant wait to see the finished look with the wheels on, should look properly awesome.
  3. #63
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    Thanks Craig .

    I did some more work last night.

    Installed 47mm twin core alloy radiator, S15 injectors, Z32 AFM and ARC super induction box. Also switched my ECU settings over to suit these parts (I have an extra daughterboard in my OEM ECU with a small external switch to go between the normal and aftermarket maps).

    I had the S15/Z32 parts on the car before I went to Japan but it was all off the car for blue slip.

    I swapped the whole plenum over as well, the one on the car was corroded (the SR in this car was a swap and the engine was likely sitting in the weather for a while or something before the swap, it's a bit corroded all over) and i had a spare one in the shed so it seemed like a good idea. I also painted all the corroded cad plated fittings on the plenum and generally tried to make it look good. It took ages to do though, the plenum is fiddly to get in and out with it's little air and water lines behind it and so on. Scraped a few knuckles in the process!

    The car isn't running now though, on startup it flooded, I suspect that that injector o rings may be leaking (easy enough to check later when i have some time, the injectors have been sitting for 2 years now as well) or perhaps one of the injectors is stuck. It could also be the AFM which has been sitting for 2 years or the reg on the rail i used (it's a different rail to what was running in the car before).

    The engine bay sure does look better now though . Pics later.
  4. #64
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    Need to get some new lower injector o rings (the little ones) and i'll get some pintle caps while i'm at it (the oem ones are all crumbled off and non existant).
    So this is how the engine bay looks right now.

    Need to give it a bit of a clean in some spots, and the induction box filter looks kind of ratty too haha.




    The coilover springs are arriving tomorrow, but i'm away for over a week from tomorrow evening so it'll just sit until i come back now!

    Not much left to go now though....well not much until it's mechanically done for a few weeks.... then onto the aesthetics some more .
  5. #65
    Member DaN[e]'s Avatar
    Join Date
    May 2007
    Location
    Sydney
    Daily
    S14a
    Posts
    278

    cars looking good.....what kind of alloy radiator is that?
  6. #66
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    Mr China brand .
  7. #67
    Member Modified's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, NSW
    Daily
    Mitsi Outlander
    2nd Car
    BNR32
    Posts
    1,683

    This car is awesome.

    Pretty much what I'm aiming for with my Silv.
    Rad-tastic: Radically Fantastic
    My Sil80 - Just a Street Car
  8. #68
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    No pics today, but I did some more work (finally!!) on the car last night.

    Put in my front coilovers again (HSD HR) but this time with 7kg springs.
    Put in the bigger aftermarket front swaybar from my 180sx in Japan.
    Put in my cusco tension rod brace (also from my 180sx in Japan).
    Straightened the tension rod brackets (they had been bashed a fair few times).
    Re-installed my S15 injectors with new o-rings and pintle caps.

    So it's all going well on that front, I've not touched the rear suspension but that will go in tonight. The car felt a bit flat on the road this morning driving to work, but it could be any number of things:
    It is a bit flat (unknown reason)
    New quiet exhaust makes it seem slower.
    My 180sx was faster so this seems slow.

    The exhaust vibrates a fair bit too, so i'll have to look a the mountings sometime. But not yet, it's a fairly minor point right now, just annoying.

    That's something to worry about after i have all the suspension and alignment sorted though.

    This arvo I'll do the rear suspension and align it and it'll be all good in that department at least!
  9. #69
    Member
    Join Date
    Aug 2007
    Location
    NSW
    Daily
    MC
    Posts
    832

    how come you're doing a full revamp of the car?
  10. #70
    Member nebuchernezzer's Avatar
    Join Date
    May 2008
    Location
    Brisbane, QLD
    Daily
    CD5 Accord, S13 Silvia
    2nd Car
    810 200B S12 Gazelle
    Name
    Jarich
    Posts
    2,196

    Partly changing stuff and partly cos i put the whole thing back to stock for a blueslip recently.

    Did some more stuff done tonight, but i'm too lazy to post it up right now haha.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •